NissanPure.com:

Username:   Password:   Remember Me?    *Login
* FAQ


Post new thread Reply to topic  [ 11 posts ] 
Author Message
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#1 - 09-05-2014, 8:23 AM.



Basically the car shuts off after driving for approximately 20 minutes. He thought the problem could be the fuel pump (aftermarket), so he replaced it and it actually kind of work but the problem still persisted. I told him to check his fuses but he says he doubts that a fuse could be the problem. He told me the car starts up perfectly, no grinds no nothing. He also put in a brand new battery, oil change, the whole nine yards yet the problem still occurs.

Once the car shuts off it will not turn on for a couple of hours. But once the hours past he says the car starts right up again like nothing happened. He says it is fuel related.

Also, the reason he says it's probably fuel related is because once the car shuts off he sprays brake cleaner into the fuel lines and he says it starts right up.

Any suggestions as to what it might be will be helpful, thank you.

Top  
 

The Boss
User avatar
Joined: Nov 2013
Location: Orlando, FL
Posts: 351
Drives: S13.5 Nissan 240sx (Fastback)

Offline 
#2 - 09-05-2014, 11:02 AM.



Coolant Temperature Sensor for the ECU. It is faulty. If the sensor thinks the water temperature is too hot it will shut the car down and won't let it start back up until it cools off. Either that or the car is actually overheating on him, lol.
_________________
ImageImage

Top  
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#3 - 09-05-2014, 11:34 AM.



So nothing in my previous post describes the car needing a distributor, correct?

Let's say we change the CTS, and the problem still happens what should we focus on next?

Also thanks!


Last edited by acslater9 on 09-05-2014, 11:35 AM.
Top  
 

The Boss
User avatar
Joined: Nov 2013
Location: Orlando, FL
Posts: 351
Drives: S13.5 Nissan 240sx (Fastback)

Offline 
#4 - 09-05-2014, 11:54 AM.



I can almost guarantee the CTS is the problem.
_________________
ImageImage

Top  
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#5 - 09-05-2014, 12:14 PM.



Alright cool, he's going to try that now. I'll update in a few.


Last edited by acslater9 on 09-05-2014, 12:14 PM.
Top  
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#6 - 09-05-2014, 6:21 PM.



Still happening. This time the car doesn't even stay on for at least a minute.

Top  
 

The Boss
User avatar
Joined: Nov 2013
Location: Orlando, FL
Posts: 351
Drives: S13.5 Nissan 240sx (Fastback)

Offline 
#7 - 09-05-2014, 8:11 PM.



Check ECU for codes. Get a fuel pressure gauge and check fuel pressure.
_________________
ImageImage

Top  
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#8 - 09-06-2014, 3:52 PM.



Checked codes nothing came up. Going to check fuel pressure.

By the way what should I be looking at once I check the fuel pressure? To see if it's getting fuel to the engine?

Top  
 

The Boss
User avatar
Joined: Nov 2013
Location: Orlando, FL
Posts: 351
Drives: S13.5 Nissan 240sx (Fastback)

Offline 
#9 - 09-06-2014, 4:08 PM.



To see if pressure is correct at idle, when giving throttle etc. For a stock KA pressure at idle should be around 34 psi when the car is warmed up, about 40 when the vacuum is unplugged.
_________________
ImageImage

Top  
 

Novice
Joined: Feb 2014
Posts: 33
Drives: 91' Nissan 240sx

Offline 
#10 - 09-06-2014, 8:29 PM.



Gotcha makes sense. Also what if the fuel pressure doesn't meet the requirements. What could possibly be the problem?


Last edited by acslater9 on 09-06-2014, 8:30 PM.
Top  
 

The Boss
User avatar
Joined: Nov 2013
Location: Orlando, FL
Posts: 351
Drives: S13.5 Nissan 240sx (Fastback)

Offline 
#11 - 09-06-2014, 8:43 PM.



If its too low, could be fuel pump, bad fuel pressure regulator, or power to fuel pump. Too high could be a blocked fuel filter or bad FPR.
_________________
ImageImage

Top  
Display posts from previous:  Sort by  
Post new thread Reply to topic  [ 11 posts ] 

Username:   Password:   Remember Me?    *Login
* FAQ

Who is online

Users viewing this topic: No registered users and 1 guest


You cannot post new threads in this forum
You cannot reply to threads in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
It is currently 10-16-2018, 9:47 AM.
All times are UTC - 5 hours

Powered by phpBB® Forum Software © phpBB Group
Copyright © 2013 - 2016, NissanPure.com
[ Time : 0.042s | 17 Queries | GZIP : Off ]